Browse more support articles…

If you are having any of the following problems, your company's IT security settings may be blocking your access to Wastebits:

  • Can't log in, even when using the correct password
  • You were supposed to receive an email to claim your account, but it didn't come through - even to your Spam box
  • You downloaded a Wastebits-compatible browser, and still can't access the site
  • You have entered the correct web address for your Wastebits portal, and still aren't able to log on

If you have tried all of these troubleshooting measures and still can't access Wastebits, you may need to ask your IT Department to "whitelist" Wastebits.


Provide your IT Department with the following information:

In order for employees of your company to properly access and use Wastebits, you will need to ensure the following:

1) The employee(s) are using one of the following supported web browsers:

  • Google Chrome (preferred)
  • Internet Explorer version 11 or newer

2) Your company has the following domains whitelisted within North America and across your company's operating geographic region:

Note: Make sure to whitelist both HTTP:// and HTTPS:// including the domains and sub-domains:

  • *.wastebits.com
  • *.cloudfront.net
  • *.google-analytics.com
  • *.hotjar.com
  • s3.amazonaws.com
  • *.sendgrid.net
  • * .intercom.io
  • * .intercomcdn.com
  • *.pusher.com
  • *.localizecdn.com
  • *.fontawesome.com

3) The employee(s) are able to receive emails from: